This document outlines the steps to upgrade the Intel AMT 5.0 MEI and LMS drivers to build and run on Linux kernel 2.6.31. It also includes a patch of MEI 5.0.0.30 and LMS 5.0.0.30 to enable compilation of the MEI driver and LMS on kernel 2.6.31 respectively. The MEI and LMS 5.0.0.30 drivers can be downloaded from the SourceForge website.